OpenRoads Designer CONNECT Edition SDK Help

BestFitProfile Method

creates bestfit profile of a point collection

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public  ProfileElement BestFitProfile(double tanThreshold,double minCurveLengthP,double maxCurveLengthP,double tol,int  curveType)

Parameters

SettingDescription
   tangent threshold
   minimun vertical curve length
   maximum vertical curve length
   tolerance(unused)
   0 -parabola, 1- arc (unused)

Return Value

ProfileElement

See Also